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Renesas Synergy™ Platform 

Importing a Renesas Synergy Project  
Introduction 
This application note describes the process of importing a Renesas Synergy Project into the IAR Embedded 
Workbench® for Renesas Synergy™ (IAR EW for Synergy) or e2 studio, then building and running the project 
application. The procedure applies to IAR EW for Synergy v7.71.2 or greater, Renesas Synergy™ Standalone 
Configurator (SSC) v5.4.0.018 or greater, e2 studio ISDE version 5.4.0.018 or greater, and Synergy Software Package 
(SSP) version 1.3.0. 

Note: The NetX™ DNS project is used an example in this application note. Substitute your desired project as needed.  

Goals and Objectives 
The goal of this application note is to help you import an existing Renesas Synergy Project, such as an example 
application, into IAR EW for Synergy or e2 studio. 

Prerequisites 
As the reader of this application note, you are assumed to have some experience with the IAR EW for Synergy or 
Renesas e2 studio ISDE and SSP. For example, before you perform the procedure in this application note, you should 
follow the procedure in your board’s Quick Start Guide to build and run the Blinky project. By doing so, you will 
become familiar with IAR EW for Synergy or e2 studio and the SSP, and ensure that the debug connection to your 
board is functioning properly. 

Required Resources 
The procedure in this application note applies to all Renesas Synergy devices and development boards. To perform the 
procedure, you will need a PC running Microsoft® Windows® 7 or 10 with the following Renesas software installed: 

• A Renesas Synergy development board (for example, DK-S7G2) 
• A PC running Microsoft® Windows® 7 or 10 with the following Renesas software installed: 

 IAR EW for Synergy v7.71.2 or greater or e2 studio ISDE v5.4.0.018 or greater 
 Synergy Software Package (SSP) v1.3.0 
 Renesas Synergy™ Standalone Configurator (SSC) v5.4.0.018 or greater (only for IAR EW for Synergy). 

 
You can download the required Renesas software from the Renesas Synergy Gallery 
(https://synergygallery.renesas.com). 
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1. Import Project into IAR EW for Synergy 

1.1 Importing an Existing Project into IAR EW for Synergy 
1. Start by opening IAR EW for Synergy.  
2. Unzip the example “NETX_DNS_DK-S7G2.zip” to a known destination folder, for 

example...\Desktop\NETX_DNS_DK-S7G2. 
3. Open the IAR EW workspace file (.eww) by clicking on File >Open >Workspace. Navigate to the folder 

where the NETX_DNS_DK-S7G2.zip or a similar zip project has been extracted to. Select the 
NETX_DUO_DNS.eww workspace file (.eww) and click Open. 

 

 
Figure 1.1 Open Workspace in IAR EW for Synergy 

1.  After opening the project, you should see the following project structure from Figure 1.2 in the IAR EW for 
Synergy IDE. 

 
Figure 1.2 Project loaded in IAR EW for Synergy 

1.2 Generating the Project Files in the IAR EW for Synergy 
Now that the project has been successfully loaded, you can start configuring the project for your hardware. 

Before starting the file generation, it is necessary to set the path to the Renesas Synergy™ Standalone Configurator 
(SSC) and Synergy Software Package (SSP). This is requested by default if you don’t follow the next steps. 

To generate the project files: 
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1. Click Renesas Synergy >Settings to open the Renesas Synergy Settings. If the License file and the SSC/SSP 
folder are already configured, the License area and SSC/SSP location of the form is as shown in Figure 1.3. If so, 
skip to step 3. 

 
Figure 1.3 SSC/SSP settings 

2. If the License area and SSC/SSP location of the form is empty, or not pointing to “C:\Renesas\Synergy\SSC”, 
continue with the steps below (A to F). These settings only need to be done once.  

A. Click the browse <…> button for the SSC/SSP location. The IAR EW for Synergy IDE displays the Open 
Dialog box.  
Note:    If you installed the SSC/SSP to the default location, then SSC/SSP folder is located in 
“C:\Renesas\Synergy\SSC” directory. 

 
Figure 1.4 SSC folder 

B. Click Choose to set the SSC/SSP location. 
C. Click the Browse <…> button for the license file. The IAR EW for Synergy IDE displays the Open Dialog 

box. 
Note: The SSP license is located in 
C:\Renesas\Synergy\SSC\intenal\projectgen\arm\Licenses directory. 
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D. Select the “SSP_License_Example_EvalLicence_*.xml” or 
“SSP_Development_and_Production_License_*.xml” located in the directory. 

 
Figure 1.5 XML SSP License file 

E. Click Open to set the License file and confirm the configuration window by clicking OK. 
F. Shortcuts are also available for the Renesas Synergy Settings and the Synergy Configurator in the IDE. 

 
Figure 1.6 Shortcuts for SCC/SSP settings 

3. Open the Synergy™ Standalone Configurator, by clicking Renesas Synergy > Configurator. See Figure 1.7. 

 
Figure 1.7 Synergy™ Standalone Configurator 

Note:  At this point, the “synergy” and “synergy_cfg” folders have not been created. These two folders contain the SSP 
generated files. The next step generates those files. 
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4. In the Synergy Standalone Configuration window, click the Generate Project Content button.  

 
Figure 1.8 Generate Project Content button 

5. Close the Synergy Standalone Configuration. 

 
Figure 1.9 Close SCC 
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6. The project should resemble the folder structure as shown in Figure 1.10. 

 
Figure 1.10 Synergy Configuration tabs 

1.3 Building the Application 
1. Build the project by clicking the Make icon in the menu bar. You can also use the F7 short key. 

  
Figure 1.11 Build button 

2. A successful build produces an output similar to Figure 1.12. 
 

 
Figure 1.12 Error Free build 

Note: For third party code used in the application project, there can be warnings at compile time. As long as these 
warnings don't affect the functionality of the project, they can be ignored. 
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1.4 Running the Application 
The application is now ready run on the target hardware. The project settings are all generated and the default debug 
probe is the J-Link ARM. You can also make use of the IAR I-jet or I-jet Trace when debugging, if you change the 
debug driver. 

1. Verify the debug probe by clicking Project > Options > Debugger > Setup > Driver as shown in Figure 1.13. 

 
Figure 1.13 Debugger Setup 1 

2. Confirm the J-Link or IAR I-jet driver by clicking OK. 
3. Press the CTRL+D or Download and Debug button as shown in Figure 1.14, to start debugging. 

 
Figure 1.14 Debugger Setup 2 

4. Press F5 or the Go button, as shown in Figure 1.15, to start the application. 
 

 
Figure 1.15 Run button 
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Note:   The application is now running on the hardware. You can pause, stop, and resume the application using the 
debug controls, as shown in Figure 1.16. 

 
Figure 1.16 Debug control 

5. Press Ctrl + Shift +D or the Stop button to end the debug session. 
 

2. Importing Project into e2 studio ISDE 
2.1 Importing an Existing Project into e2 studio ISDE 
1. Start by opening e2 studio.  
2. Open the Workspace that you want to import the file into and skip to step D. Otherwise, proceed with the following 

steps: 
A. At the end of e2 studio startup, you see the Workspace Launcher Dialog box as shown in Figure 2.1. (If you did 

not see this dialog box, you might have turned off it off. If that is the case, open your desired project and skip 
to step D.) Otherwise, continue with the following steps.  

 
Figure 2.1 Workspace Launcher dialog 

B. Enter a new workspace name in the Workspace Launcher dialog as shown in Figure 2.2. e2 studio creates a new 
workspace with this name. 

 
Figure 2.2 Workspace Launcher dialog 



Renesas Synergy™ Platform  Importing a Renesas Synergy Project 

R11AN0023EU0117 Rev.1.17  Page 9 of 18 
Jun 21, 2017  

C. Click OK. 
D. When the workspace is opened, you may see the Welcome Window. If that happens, click the Workbench 

arrow to proceed past the Welcome Screen as seen in Figure 2.3. 

 
Figure 2.3 Workbench arrow 

3. You are now in the workspace that you want to import the project into. Click the File menu in the menu bar, as 
shown in Figure 2.4. 

 
 
 

   Menu Bar 
 
 

Tool Bar 
  
   

Figure 2.4 Menu and tool bar 

4. Click Import on the File menu, in the menu bar, as shown in Figure 2.5. 

 
Figure 2.5 File drop-down menu   
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5. In the Import dialog box, as shown in Figure 2.6, choose the General option, then Existing Projects into 
Workspace, to import the project into the current workspace. 

   
Figure 2.6 Project Import dialog with “Existing Projects into Workspace” option selected 

6. Click Next. 
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7. Click Select archive file as shown in Figure 2.7.  

   
Figure 2.7 Import Existing Project dialog 1 

8. Click Browse. 
9. Browse to the folder where the zip file for the project you want to import is located.  
10. Select the file for import. In our example, it is “NETX_DNS_DK-S7G2.zip”. 
11. Click Open. 
12. Select the Project to import from the list of Projects, as shown in Figure 2.8. 

 
Figure 2.8 Import Existing Project dialog 2 

13. Click Finish to import the project.  

2.2 Installing the Synergy License 
Building and running example applications requires a Synergy license to be installed in e2 studio. If this license is not 
installed, a yellow box is displayed in the lower right hand corner of the ISDE after you have imported your example 
application. 
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Figure 2.9 Synergy License Required prompt 

1. To install the license, click “Click here to set up the license”. This takes you to the Synergy License setup 
window. 

  
Figure 2.10 Synergy License file 

Pressing the two Browse buttons takes you to the folder where your default Synergy License is stored. Select this file to 
install the license. Once this is done, the yellow window disappears and building can begin. 

2.3 Generating the Project Files in the ISDE 
Now that the project has been successfully imported, you can start configuring the project for the hardware. 

1. If the Project Explorer looks like Figure 2.11, click the arrow to the left to expand the project.   

 
Figure 2.11 Collapsed Project Explorer 
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2. Open the Synergy Configuration, if not already open, by double-clicking the configuration.xml file in the 
Project Explorer, as shown in Figure 2.12. 

 
Figure 2.12 Project Explorer   

Note: At this point, the synergy and synergy_cfg folders have not been created. These two folders contain files 
generated by e2 studio and the SSP. The next step generates these files.  

3. In the Synergy Configuration window, click the Generate Project Content button.  

   
Figure 2.13 Generate Project Content button 
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4. The project should resemble the folder structure shown in Figure 2.14. 

  
Figure 2.14 Synergy Configuration tabs 

2.4 Building the Application 
Build the project by clicking the hammer icon as seen in the menu bar in Figure 2.15. 

    
Figure 2.15 Build button 

A successful build produces an output similar to Figure 2.16. 

   
Figure 2.16 Error free build 

2.5 Running the Application 
The application is now ready to run on the target hardware. 

To run the application: 
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1. Click the drop-down menu for the debug icon, as shown in Figure 2.17. 

  
Figure 2.17 Debug options 

2. Select the Debug Configurations... option. 
3. Under the Renesas GDB Hardware Debug section, select the name of the project, which in this case is 

NETX_DNS_SK_S7G2 Debug. 
4. Make sure that the “.elf” file name matches the one generated by the project inside of the debug folder. 
 

 
Figure 2.18 Debug Configurations window 
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5. Click the Debugger tab on the right side of the dialog box. 
6.  Ensure the Debug hardware setting is set to J-Link ARM. If not, change it using the drop-down menu. 
7.  Ensure the Target Device setting matches the target hardware. If it does not match, click the “…” button to select 

the correct target device from the Synergy device list. 

 
Figure 2.19 Debug Configurations Debugger setup 

8. Press the Debug button to start debugging. 

   
Figure 2.20 Debug button 

9. Select Yes to open the Debug Perspective. 

   
Figure 2.21 Perspective Switch dialog 
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10. Press F8 or the Resume button to start the application. 

   
Figure 2.22 Resume button 

11. Press F8 or the Resume button at main to continue. 
Note: The application is now running on the hardware. You can pause, stop, and resume the application using the 

debug controls shown in Figure 2.23. 
12. Press Ctrl + F2 or the Stop button to end the debug session. 
13. Press the Synergy Configuration button to return to the Synergy Perspective. 
 

   
Figure 2.23 Perspective options 

3. Next Steps 
After you run the example application, you can learn more about how the application works, and the API calls involved, 
by examining the application source code. 

You can also download additional Synergy example applications from the following URL: 
https://www.renesas.com/en-us/products/embedded_systems_platform/synergy/sample-code.html  

https://www.renesas.com/en-us/products/embedded_systems_platform/synergy/sample-code.html
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Website and Support  
Support:  https://synergygallery.renesas.com/support 

Technical Contact Details: 

• America: https://renesas.zendesk.com/anonymous_requests/new   
• Europe: https://www.renesas.com/en-eu/support/contact.html  
• Japan: https://www.renesas.com/ja-jp/support/contact.html 
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Notice
1. Descriptions of circuits, software and other related information in this document are provided only to illustrate the operation of semiconductor products and application examples. You are fully responsible for

the incorporation or any other use of the circuits, software, and information in the design of your product or system. Renesas Electronics disclaims any and all liability for any losses and damages incurred by

you or third parties arising from the use of these circuits, software, or information.

2. Renesas Electronics hereby expressly disclaims any warranties against and liability for infringement or any other disputes involving patents, copyrights, or other intellectual property rights of third parties, by or

arising from the use of Renesas Electronics products or technical information described in this document, including but not limited to, the product data, drawing, chart, program, algorithm, application

examples.

3. No license, express, implied or otherwise, is granted hereby under any patents, copyrights or other intellectual property rights of Renesas Electronics or others.

4. You shall not alter, modify, copy, or otherwise misappropriate any Renesas Electronics product, whether in whole or in part. Renesas Electronics disclaims any and all liability for any losses or damages

incurred by you or third parties arising from such alteration, modification, copy or otherwise misappropriation of Renesas Electronics products.

5. Renesas Electronics products are classified according to the following two quality grades: "Standard" and "High Quality". The intended applications for each Renesas Electronics product depends on the

product’s quality grade, as indicated below.

"Standard": Computers; office equipment; communications equipment; test and measurement equipment; audio and visual equipment; home electronic appliances; machine tools; personal electronic

equipment; and industrial robots etc.

"High Quality": Transportation equipment (automobiles, trains, ships, etc.); traffic control (traffic lights); large-scale communication equipment; key financial terminal systems; safety control equipment; etc.

Renesas Electronics products are neither intended nor authorized for use in products or systems that may pose a direct threat to human life or bodily injury (artificial life support devices or systems, surgical

implantations etc.), or may cause serious property damages (space and undersea repeaters; nuclear power control systems; aircraft control systems; key plant systems; military equipment; etc.). Renesas

Electronics disclaims any and all liability for any damages or losses incurred by you or third parties arising from the use of any Renesas Electronics product for which the product is not intended by Renesas

Electronics.

6. When using the Renesas Electronics products, refer to the latest product information (data sheets, user’s manuals, application notes, "General Notes for Handling and Using Semiconductor Devices" in the

reliability handbook, etc.), and ensure that usage conditions are within the ranges specified by Renesas Electronics with respect to maximum ratings, operating power supply voltage range, heat radiation

characteristics, installation, etc. Renesas Electronics disclaims any and all liability for any malfunctions or failure or accident arising out of the use of Renesas Electronics products beyond such specified

ranges.

7. Although Renesas Electronics endeavors to improve the quality and reliability of Renesas Electronics products, semiconductor products have specific characteristics such as the occurrence of failure at a

certain rate and malfunctions under certain use conditions. Further, Renesas Electronics products are not subject to radiation resistance design. Please ensure to implement safety measures to guard them

against the possibility of bodily injury, injury or damage caused by fire, and social damage in the event of failure or malfunction of Renesas Electronics products, such as safety design for hardware and

software including but not limited to redundancy, fire control and malfunction prevention, appropriate treatment for aging degradation or any other appropriate measures by your own responsibility as warranty

for your products/system.  Because the evaluation of microcomputer software alone is very difficult and not practical, please evaluate the safety of the final products or systems manufactured by you.

8. Please contact a Renesas Electronics sales office for details as to environmental matters such as the environmental compatibility of each Renesas Electronics product. Please investigate applicable laws and

regulations that regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive carefully and sufficiently and use Renesas Electronics products in compliance with all

these applicable laws and regulations.  Renesas Electronics disclaims any and all liability for damages or losses occurring as a result of your noncompliance with applicable laws and regulations.

9. Renesas Electronics products and technologies shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is prohibited under any applicable domestic or foreign laws

or regulations. You shall not use Renesas Electronics products or technologies for (1) any purpose relating to the development, design, manufacture, use, stockpiling, etc., of weapons of mass destruction,

such as nuclear weapons, chemical weapons, or biological weapons, or missiles (including unmanned aerial vehicles (UAVs)) for delivering such weapons, (2) any purpose relating to the development,

design, manufacture, or use of conventional weapons, or (3) any other purpose of disturbing international peace and security, and you shall not sell, export, lease, transfer, or release Renesas Electronics

products or technologies to any third party whether directly or indirectly with knowledge or reason to know that the third party or any other party will engage in the activities described above. When exporting,

selling, transferring, etc., Renesas Electronics products or technologies, you shall comply with any applicable export control laws and regulations promulgated and administered by the governments of the

countries asserting jurisdiction over the parties or transactions.

10. Please acknowledge and agree that you shall bear all the losses and damages which are incurred from the misuse or violation of the terms and conditions described in this document, including this notice,

and hold Renesas Electronics harmless, if such misuse or violation results from your resale or making Renesas Electronics products available any third party.

11. This document shall not be reprinted, reproduced or duplicated in any form, in whole or in part, without prior written consent of Renesas Electronics.

12. Please contact a Renesas Electronics sales office if you have any questions regarding the information contained in this document or Renesas Electronics products.

(Note 1) "Renesas Electronics" as used in this document means Renesas Electronics Corporation and also includes its majority-owned subsidiaries.

(Note 2) "Renesas Electronics product(s)" means any product developed or manufactured by or for Renesas Electronics.

http://www.renesas.com
Refer to "http://www.renesas.com/" for the latest and detailed information.
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